Remove initramfs workaround for u-boot environment.

Early in the dev-4.4 kernel lifetime a workaround was developed when the
fw_setenv command was failing. That issue does not appear with the
current kernel and the workaround can be removed.

Change-Id: I2a0f01f274b7ce76fbd1e80fe901cc86087ee5d8
Signed-off-by: Edward A. James <eajames@us.ibm.com>
diff --git a/common/recipes-bsp/u-boot/u-boot-fw-utils_%.bbappend b/common/recipes-bsp/u-boot/u-boot-fw-utils_%.bbappend
new file mode 100644
index 0000000..a460f40
--- /dev/null
+++ b/common/recipes-bsp/u-boot/u-boot-fw-utils_%.bbappend
@@ -0,0 +1,6 @@
+SRC_URI += "file://76-mtd-partitions.rules"
+
+do_install_append() {
+	install -d ${D}/${base_libdir}/udev/rules.d/
+        install ${WORKDIR}/76-mtd-partitions.rules ${D}/${base_libdir}/udev/rules.d/
+}