meta-phosphor: drop systemd 239 patches

Upstream has moved to systemd 241 and thus several backported patches
can be dropped.

Change-Id: I0ccc6f432a416026cae4943b74d6c1ecc048eb51
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/recipes-core/systemd/systemd_%.bbappend b/recipes-core/systemd/systemd_%.bbappend
index 680f4f6..fa6a7ed 100644
--- a/recipes-core/systemd/systemd_%.bbappend
+++ b/recipes-core/systemd/systemd_%.bbappend
@@ -1,23 +1,13 @@
 FILES_${PN}-catalog-extralocales = \
             "${exec_prefix}/lib/systemd/catalog/*.*.catalog"
 PACKAGES =+ "${PN}-catalog-extralocales"
-PACKAGECONFIG_remove = "backlight binfmt firstboot hibernate ima \
-                        localed logind machined polkit quotacheck smack utmp \
-                        vconsole"
+PACKAGECONFIG_remove = "backlight binfmt firstboot gshadow hibernate ima \
+                        localed logind machined nss nss-mymachines nss-resolve \
+                        polkit quotacheck smack utmp vconsole"
+
 FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
 SRC_URI += "file://default.network"
 SRC_URI += "file://0001-sd-bus-Don-t-automatically-add-ObjectManager.patch"
-SRC_URI += "file://0006-core-fix-the-check-if-CONFIG_CGROUP_BPF-is-on.patch"
-
-# Static neighbor support included in v240 so remove when updated
-SRC_URI += "file://0001-networkd-Track-address-configuration.patch"
-SRC_URI += "file://0002-networkd-Use-only-a-generic-CONFIGURING-state.patch"
-SRC_URI += "file://0003-networkd-Static-neighbor-support.patch"
-
-# Fixes from upstream for openbmc/openbmc#3459
-SRC_URI += "file://0001-timedate-defer-the-property-changed-signal-until-job.patch"
-SRC_URI += "file://0001-timedate-treat-activating-or-inactivating-NTP-client.patch"
-SRC_URI += "file://0002-timedate-refuse-to-set-time-when-previous-request-is.patch"
 
 RRECOMMENDS_${PN} += "obmc-targets"
 FILES_${PN} += "${systemd_unitdir}/network/default.network"