openssl: Don't add c_rehash

This script was rewritten into perl at some point and brings in an
unnecessary runtime dependency on perl.

Tested:
    Built a romulus openbmc image and verified that c_rehash and perl
    were no longer included.

Change-Id: I2f62c22ea764ef1b6c684c85641ee327bfeb3320
Signed-off-by: William A. Kennington III <wak@google.com>
diff --git a/recipes-connectivity/openssl/openssl_%.bbappend b/recipes-connectivity/openssl/openssl_%.bbappend
index 51e64ad..004d8dc 100644
--- a/recipes-connectivity/openssl/openssl_%.bbappend
+++ b/recipes-connectivity/openssl/openssl_%.bbappend
@@ -12,3 +12,7 @@
 do_configure_append() {
     oe_runmake depend
 }
+
+# We don't want to depend on perl in our image
+RDEPENDS_${PN}-bin_remove = "perl"
+FILES_${PN}-misc_append = " ${bindir}/c_rehash"