devtools: iotools: add service to create symlinks

The iotools binary is meant to be called via symlinks, similarly to
busybox.  Therefore, the recipe should provide a service that kicks that
off for the user.

Change-Id: I64b69bf18bd39e324ba9c6922cdf08b88caf43e2
Signed-off-by: Patrick Venture <venture@google.com>
diff --git a/common/recipes-devtools/iotools/iotools_1.6.bb b/common/recipes-devtools/iotools/iotools_1.6.bb
index 0fc872d..2a39286 100644
--- a/common/recipes-devtools/iotools/iotools_1.6.bb
+++ b/common/recipes-devtools/iotools/iotools_1.6.bb
@@ -6,6 +6,8 @@
 SRC_URI = "git://git@github.com/jonmayergoogle/iotools.git;protocol=https"
 PV = "v1.6+git${SRCPV}"
 
+inherit obmc-phosphor-systemd
+
 S = "${WORKDIR}/git"
 FILES_${PN} = "${sbindir}"
 
@@ -20,3 +22,5 @@
     install -d ${D}${sbindir}
     install -m 0755 iotools ${D}${sbindir}
 }
+
+SYSTEMD_SERVICE_${PN} += "iotools-setup.service"