dunfell: sysvinit package needed for /run/lock

Upstream systemd made the inclusion of the tmpfiles.d/legacy.conf a
feature that is only provided if the sysvinit PACKAGE is set. By default
systemd upstream sets this but OpenBMC overrides that in this file.

The legacy.conf provides among other things, a creation of the
/run/lock directory.

Applications like fw_printenv and fw_setenv rely on the /run/lock
directory being present.

opened systemd/systemd#15668 to see if there could be a more efficient
way of getting /run/lock. Tying it to sysvinit and having it in a file
called legacy.conf just doesn't make a lot of sense to me.

Tested: Verified /run/lock is now present in QEMU boot and that
fw_printenv worked.

Change-Id: Ib508ec05b71eba6173b9f3552b02260ace5c5a69
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/recipes-core/systemd/systemd_%.bbappend b/recipes-core/systemd/systemd_%.bbappend
index 16ba8f7..5aef993 100644
--- a/recipes-core/systemd/systemd_%.bbappend
+++ b/recipes-core/systemd/systemd_%.bbappend
@@ -2,7 +2,7 @@
             "${exec_prefix}/lib/systemd/catalog/*.*.catalog"
 PACKAGES =+ "${PN}-catalog-extralocales"
 PACKAGECONFIG = "pam hostnamed networkd randomseed resolved sysusers timedated \
-                 timesyncd xz kmod coredump"
+                 timesyncd xz kmod coredump sysvinit"
 
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 SRC_URI += "file://default.network"