install host state transition services

See the following for more details:
https://gerrit.openbmc-project.xyz/c/openbmc/phosphor-state-manager/+/39359

This will install the services required to get the TransitionToRunning
and TransitionToOff support for CurrentHostState.

Includes following in bump:

    Andrew Geissler (1):
          host state transitioning support

Tested:
- Verified CurrentHostState changed as expected doing a host on, off,
  and reboot.

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I5cf2ea840744fa179585b032a00e453219d237c3
diff --git a/recipes-phosphor/state/phosphor-state-manager_git.bb b/recipes-phosphor/state/phosphor-state-manager_git.bb
index 8e74e69..4a1854e 100644
--- a/recipes-phosphor/state/phosphor-state-manager_git.bb
+++ b/recipes-phosphor/state/phosphor-state-manager_git.bb
@@ -59,6 +59,8 @@
 DBUS_SERVICE_${PN}-host += "phosphor-reboot-host@.service"
 SYSTEMD_SERVICE_${PN}-host += "phosphor-reset-host-reboot-attempts@.service"
 SYSTEMD_SERVICE_${PN}-host += "phosphor-clear-one-time@.service"
+SYSTEMD_SERVICE_${PN}-host += "phosphor-set-host-transition-to-running@.service"
+SYSTEMD_SERVICE_${PN}-host += "phosphor-set-host-transition-to-off@.service"
 
 FILES_${PN}-chassis = "${bindir}/phosphor-chassis-state-manager"
 DBUS_SERVICE_${PN}-chassis += "xyz.openbmc_project.State.Chassis.service"
@@ -174,6 +176,6 @@
 SYSTEMD_LINK_${PN}-obmc-targets += "${@compose_list(d, 'QUIESCE_FMT', 'HOST_ERROR_TARGETS', 'OBMC_HOST_INSTANCES')}"
 
 SRC_URI += "git://github.com/openbmc/phosphor-state-manager"
-SRCREV = "bbbc01655243fecc83f8734f12a57e665b90ff9a"
+SRCREV = "1e8b164f7b575f9728dd7f46d7b2d27e6081ee3f"
 
 S = "${WORKDIR}/git"