sdbusplus: convert to phosphor-python-autotools inherit

Change-Id: Ifbc1a4d8d8d6d381729304f35b7e218ebef7b9e1
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
diff --git a/common/recipes-extended/sdbusplus/sdbusplus.bb b/common/recipes-extended/sdbusplus/sdbusplus.bb
index 2ae5f7c..6b38a53 100644
--- a/common/recipes-extended/sdbusplus/sdbusplus.bb
+++ b/common/recipes-extended/sdbusplus/sdbusplus.bb
@@ -6,9 +6,7 @@
 LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
 
 inherit autotools pkgconfig
-inherit pythonnative
-
-FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
+inherit obmc-phosphor-python-autotools
 
 DEPENDS += "autoconf-archive-native"
 RDEPENDS_${PN} += " \
@@ -28,9 +26,4 @@
 PACKAGECONFIG_remove_class-native = "libsdbusplus"
 PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus"
 
-export BUILD_SYS
-export HOST_SYS
-export STAGING_INCDIR
-export STAGING_LIBDIR
-
 BBCLASSEXTEND += "native nativesdk"