Providing infra for FRUs which are accessible through host but host is
not sending the details for those FRUs

- This commit adds a hand written YAML file that specifies IPMI FRU
information. It is for special case where FRU info is not coming as a
write-fru, it coming as a write-sensor from host because host doesn't
have the required i2c access to read the GPU FRU data.
- The YAML in this commit is mostly empty, and system specific overrides
are supposed to add appropriate content.

Partially Resolves openbmc/openbmc#3039

Change-Id: I20b43d1bb4c472dc590d254b72340fb19c52b811
Signed-off-by: Nagaraju Goruganti <ngorugan@in.ibm.com>
diff --git a/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-merge-config-native.bb b/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-merge-config-native.bb
index dfedab2..a44774e 100644
--- a/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-merge-config-native.bb
+++ b/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-merge-config-native.bb
@@ -1,8 +1,8 @@
 SUMMARY = "To merge the Host and BMC config files generated from MRW "
-DESCRIPTION = "Merge host provided FRU info config file and \
-BMC accessible FRU info config files generated by \
-gen-ipmi-fru.pl into a single config file. fru-gen parser \
-parses the merged config file and generates cpp file"
+DESCRIPTION = "Merge host provided FRU info config file, fru info config, \
+which is not sent by host config, and BMC accessible FRU info config \
+files generated by gen-ipmi-fru.pl into a single config file. \
+fru-gen parser parses the merged config file and generates cpp file"
 PR = "r1"
 
 inherit native
@@ -11,6 +11,7 @@
 
 DEPENDS += "virtual/phosphor-ipmi-fru-read-inventory"
 DEPENDS += "virtual/phosphor-ipmi-fru-read-bmc-inventory"
+DEPENDS += "virtual/phosphor-ipmi-fru-read-not-sent-by-host-inventory"
 PROVIDES += "virtual/phosphor-ipmi-fru-merge-config"
 
 do_install_append() {
@@ -18,4 +19,5 @@
   DEST=${D}${config_datadir}
   install -d ${DEST}
   cat ${SRC}/config.yaml ${SRC}/bmc-fru-config.yaml > ${DEST}/fru_config.yaml
+  cat ${SRC}/fru-config-not-sent-by-host.yaml >> ${DEST}/fru_config.yaml
 }