Add recipes for Phosphor inventory manager

Phosphor Inventory Manager is an inventory object lifecycle
management application suitable for a wide variety of
OpenBMC platforms.

Add recipes.
Add systemd unit.

Change-Id: I4cbaa34b3b787c2ced96efebf36b9b964ddbe8ae
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb b/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb
new file mode 100644
index 0000000..880d5ac
--- /dev/null
+++ b/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Managed inventory with Phosphor inventory manager - example"
+PR = "r1"
+
+inherit native
+
+require phosphor-inventory-manager.inc
+
+S = "${WORKDIR}/git"
+
+do_install() {
+        SRC=${S}/example
+        DEST=${D}${datadir}/phosphor-inventory-manager
+
+        for f in `find $SRC -type f -printf "%P\n"`; do
+                install -D ${SRC}/$f $DEST/$f
+        done
+}