jsnbd: Create recipe and add it to the REST server

Create a recipe for the jsnbd repo and add a dependency to the
phosphor-rest-server app since it'll require it to run.
The same dependency will be added to bmcweb in a subsequent commit.

Tested: Verified the nbd-proxy binary is added to the image.

Change-Id: I45b4613de5a895649856bc2769b9cf47eef85cf8
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/recipes-connectivity/jsnbd/jsnbd_git.bb b/recipes-connectivity/jsnbd/jsnbd_git.bb
new file mode 100644
index 0000000..4902145
--- /dev/null
+++ b/recipes-connectivity/jsnbd/jsnbd_git.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Network Block Device Proxy"
+HOMEPAGE = "https://github.com/openbmc/jsnbd"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+inherit autotools pkgconfig
+
+DEPENDS += "json-c"
+DEPENDS += "udev"
+
+S = "${WORKDIR}/git"
+
+SRC_URI = "git://github.com/openbmc/jsnbd"
+SRCREV = "fa1d37502c87310886614949a8d72124762b2dcb"