Add support for c++ futures for armv5te

Some openbmc platforms are using -march=armv5te that has
a known bug with futures. Backport patch to gcc that fixes this
issue.

original gcc git commit: c45be7f1aef92f2ea7363cbc4627f943b83ca902
gcc bug: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=64735

Change-Id: I961b104c3d55c075c13d1b8c95306e71231ca0d1
Signed-off-by: James Feist <james.feist@linux.intel.com>
diff --git a/common/recipes-devtools/gcc/gcc-source_6.2.bbappend b/common/recipes-devtools/gcc/gcc-source_6.2.bbappend
new file mode 100644
index 0000000..b7cb542
--- /dev/null
+++ b/common/recipes-devtools/gcc/gcc-source_6.2.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS_append := "${THISDIR}/gcc_6.2:"
+SRC_URI_append = "file://0001-Support-exception-propagation-without-lock-free-atom.patch"