Add virtual/phosphor-ipmi-fru-properties

This virtual provides an output file in YAML format, which has
property:value pairs for FRUs of interest.

Add a native recipe that builds the configuration from MRW. Set this
recipe as the default for OpenPOWER systems.

Change-Id: Icc816b777189a48aff79a958f38ad22d7002bfdc
Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
diff --git a/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-mrw-native.bb b/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-mrw-native.bb
new file mode 100644
index 0000000..2188f04
--- /dev/null
+++ b/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-mrw-native.bb
@@ -0,0 +1,28 @@
+SUMMARY = "FRU properties config for ipmi-fru-parser"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-ipmi-fru
+
+SRC_URI += "file://config.yaml"
+
+DEPENDS += " \
+           mrw-native \
+           mrw-perl-tools-native \
+           "
+
+PROVIDES += "virtual/phosphor-ipmi-fru-properties"
+
+S = "${WORKDIR}"
+
+do_install() {
+        DEST=${D}${properties_datadir}
+        install -d ${DEST}
+
+        ${bindir}/perl-native/perl \
+            ${bindir}/gen_fru_properties.pl \
+            -m ${datadir}/obmc-mrw/${MACHINE}.xml \
+            -c config.yaml \
+            -o ${DEST}/out.yaml
+}