Add dbus interface support for console

To support changing uart baudrate through dbus interface dynamically,
need to involve systemd for dependency.

Change-Id: Icd57c9d2f5d8fa4f99b0cac14a9e2767f355266e
Signed-off-by: Cheng C Yang <cheng.c.yang@linux.intel.com>
diff --git a/recipes-phosphor/console/obmc-console_git.bb b/recipes-phosphor/console/obmc-console_git.bb
index 60a0bbc..4d00713 100644
--- a/recipes-phosphor/console/obmc-console_git.bb
+++ b/recipes-phosphor/console/obmc-console_git.bb
@@ -6,12 +6,14 @@
 LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
 
 inherit obmc-phosphor-systemd
-inherit autotools
+inherit autotools pkgconfig
 inherit obmc-phosphor-discovery-service
 
 TARGET_CFLAGS   += "-fpic -O2"
 
-DEPENDS += "autoconf-archive-native"
+DEPENDS += "autoconf-archive-native \
+            systemd \
+            "
 
 SRC_URI += "git://github.com/openbmc/obmc-console"
 SRC_URI += "file://${PN}.conf"