Add native/sdk classes to phosphor-dbus-interfaces

Enable native and nativesdk classes for phosphor-dbus-interfaces.
Install nativesdk-phosphor-dbus-interfaces by default in the
obmc-phosphor-image sdk.

Change-Id: Iaf134734ada106bb69254dfffa07c2af2641d9f8
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/dbus/phosphor-dbus-interfaces.bb b/common/recipes-phosphor/dbus/phosphor-dbus-interfaces.bb
index 1c633ea..1b88a2f 100644
--- a/common/recipes-phosphor/dbus/phosphor-dbus-interfaces.bb
+++ b/common/recipes-phosphor/dbus/phosphor-dbus-interfaces.bb
@@ -9,9 +9,22 @@
 inherit pythonnative
 
 DEPENDS += "autoconf-archive-native"
-DEPENDS += "sdbusplus sdbus++-native"
+DEPENDS += "sdbus++-native"
 
-RDEPENDS_${PN} += "libsystemd"
+PACKAGE_BEFORE_PN = "${PN}-yaml"
+
+FILES_${PN}-yaml = "${datadir}/${PN}/yaml"
 
 SRC_URI += "git://github.com/openbmc/phosphor-dbus-interfaces"
 SRCREV = "06e5b23a3671f44c04c7f7cce83def5ff68c86b9"
+
+DEPENDS_remove_class-native = "sdbus++-native"
+DEPENDS_remove_class-nativesdk = "sdbus++-native"
+
+PACKAGECONFIG ??= "libphosphor_dbus"
+PACKAGECONFIG[libphosphor_dbus] = "--enable-libphosphor_dbus,--disable-libphosphor_dbus,sdbusplus,libsystemd"
+
+PACKAGECONFIG_remove_class-native = "libphosphor_dbus"
+PACKAGECONFIG_remove_class-nativesdk = "libphosphor_dbus"
+
+BBCLASSEXTEND += "native nativesdk"