host-ipmid: OEM command will require clear-once service

Tell systemd the host-ipmid service wants the clear-once service
to be started, and that it wants to run after the clear-once
service.

The new OEM command will use the openbmc init run once variables
set in the u-boot environment.  We want the u-boot variable
cleared before the host can request it be set again.

Tell bitbake to require the clean-once package.

Signed-off-by: Milton Miller <miltonm@us.ibm.com>
diff --git a/common/recipes-phosphor/host-ipmid/host-ipmid.bb b/common/recipes-phosphor/host-ipmid/host-ipmid.bb
index 68bd38b..9e25cd2 100644
--- a/common/recipes-phosphor/host-ipmid/host-ipmid.bb
+++ b/common/recipes-phosphor/host-ipmid/host-ipmid.bb
@@ -14,6 +14,7 @@
 
 TARGET_CFLAGS   += "-fpic"
 
+RDEPENDS_${PN} += "clear-once"
 RDEPENDS_${PN} += "settings"
 RDEPENDS_${PN} += "network"
 SRC_URI += "git://github.com/openbmc/phosphor-host-ipmid"