meta-phosphor: fru-device add predicate

Predicate building fru-device on distro support for IPMI FRU.

Change-Id: Idfaa720f86e3b9240ae2f9250abafc30b4a9a289
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/recipes-phosphor/configuration/entity-manager_git.bb b/recipes-phosphor/configuration/entity-manager_git.bb
index 8660db7..140b8cb 100644
--- a/recipes-phosphor/configuration/entity-manager_git.bb
+++ b/recipes-phosphor/configuration/entity-manager_git.bb
@@ -10,13 +10,15 @@
 LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"
 
 SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.EntityManager.service \
-                         xyz.openbmc_project.FruDevice.service"
+                         ${@bb.utils.contains('DISTRO_FEATURES', 'ipmi-fru', 'xyz.openbmc_project.FruDevice.service', '', d)}"
 
 DEPENDS = "boost \
-           i2c-tools \
            nlohmann-json \
            sdbusplus \
            valijson"
 
 S = "${WORKDIR}/git/"
 inherit meson systemd
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipmi-fru', d)}"
+PACKAGECONFIG[ipmi-fru] = "-Dfru-device=true, -Dfru-device=false, i2c-tools,"