python: Install full email package for native[sdk]

The .bbappend for python creates a minimal email package for
installation on the target, but was also impacting nativesdk
packages.  This prevented us from compiling certain python
programs inside the SDK.  Change the do_install_append to
only impact targets (and not native/nativesdk).

Change-Id: I68576d7f1f98892840a09ed382690ea4b3aa3940
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
diff --git a/common/recipes-devtools/python/python_2.7.11.bbappend b/common/recipes-devtools/python/python_2.7.11.bbappend
index a4df15b..569e753 100644
--- a/common/recipes-devtools/python/python_2.7.11.bbappend
+++ b/common/recipes-devtools/python/python_2.7.11.bbappend
@@ -1,7 +1,7 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 SRC_URI += "file://__init__.email_min.py"
 
-do_install_append() {
+do_install_append_class-target() {
 	dir=${libdir}/python${PYTHON_MAJMIN}/email
         mv ${D}/$dir/__init__.py \
                 ${D}/$dir/email_full.py