Enabling the avahi service.

Regsitering the following services with avahi.
obmc-console,ssh,sftp(dropbear),obmc-rest

Fixes openbmc/openbmc#548
Fixes openbmc/openbmc#549

Change-Id: I20c31e9e8dfa6d52575bc3c1f55ac62eef82ec13
Signed-off-by: Ratan Gupta <ratagupt@in.ibm.com>
diff --git a/common/recipes-core/dropbear/dropbear_%.bbappend b/common/recipes-core/dropbear/dropbear_%.bbappend
index 52a38bd..51a98d4 100644
--- a/common/recipes-core/dropbear/dropbear_%.bbappend
+++ b/common/recipes-core/dropbear/dropbear_%.bbappend
@@ -1,3 +1,7 @@
+inherit obmc-phosphor-discovery-service
+
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 SRC_URI += "file://dropbearkey.service \
 	    file://0001-dropbear-Add-c-command-option-to-force-a-specific-co.patch"
+
+REGISTERED_SERVICES_${PN} += "ssh:tcp:22 sftp:tcp:22"