Enabling the avahi service.

Regsitering the following services with avahi.
obmc-console,ssh,sftp(dropbear),obmc-rest

Fixes openbmc/openbmc#548
Fixes openbmc/openbmc#549

Change-Id: I20c31e9e8dfa6d52575bc3c1f55ac62eef82ec13
Signed-off-by: Ratan Gupta <ratagupt@in.ibm.com>
diff --git a/common/recipes-phosphor/interfaces/phosphor-rest.bb b/common/recipes-phosphor/interfaces/phosphor-rest.bb
index a8f82cb..8df4ca0 100644
--- a/common/recipes-phosphor/interfaces/phosphor-rest.bb
+++ b/common/recipes-phosphor/interfaces/phosphor-rest.bb
@@ -8,6 +8,7 @@
 inherit allarch
 inherit obmc-phosphor-systemd
 inherit setuptools
+inherit obmc-phosphor-discovery-service
 
 RRECOMMENDS_${PN} += "virtual-obmc-wsgihost"
 
@@ -29,3 +30,4 @@
 SYSTEMD_SERVICE_${PN} = ""
 SYSTEMD_OVERRIDE_${PN} += "rest-dbus.conf:obmc-mapper.target.d/rest-dbus.conf"
 SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/wsgi_app"
+REGISTERED_SERVICES_${PN} += "phosphor_rest:tcp:443"