meta-phosphor: systemd: rework PACKAGECONFIG

Phosphor removes a number of systemd packageconfigs that are enabled by
default in oe-core.  Sort the removal list alphabetically.

Remove networkd.  It is now selected by default in oe-core.

Remove vconsole.  Typically vconsoles aren't needed on a BMC and
vconsole support has significant footprint cost.

Remove ldconfig.  The base recipe controls this via distro feature;
don't override.

Remove kdbus and bootchart.  They aren't options anymore.

Change-Id: I0faff1b9eade0cd1753156b08b798474bc262293
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/recipes-core/systemd/systemd_%.bbappend b/recipes-core/systemd/systemd_%.bbappend
index 9611cab..7ab626e 100644
--- a/recipes-core/systemd/systemd_%.bbappend
+++ b/recipes-core/systemd/systemd_%.bbappend
@@ -1,10 +1,9 @@
 FILES_${PN}-catalog-extralocales = \
             "${exec_prefix}/lib/systemd/catalog/*.*.catalog"
 PACKAGES =+ "${PN}-catalog-extralocales"
-PACKAGECONFIG_append = " networkd"
-PACKAGECONFIG_remove = "machined hibernate ldconfig binfmt backlight localed \
-                        quotacheck kdbus ima smack polkit logind bootchart utmp \
-                        manpages"
+PACKAGECONFIG_remove = "backlight binfmt firstboot hibernate ima \
+                        localed logind machined polkit quotacheck smack utmp \
+                        vconsole"
 FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
 SRC_URI += "file://default.network"
 SRC_URI += "file://0001-sd-bus-Don-t-automatically-add-ObjectManager.patch"