Add python library pamela as a dependency of phosphor-rest-server

Pamela is a python wrapper for PAM. Compared to python-pam it has wrapper for
account management in addition to authentication.

Change-Id: I1c24805b408057941fbb7230374a55eeabeede19
Signed-off-by: Tom Joseph <tomjoseph@in.ibm.com>
diff --git a/recipes-devtools/python/pamela_0.3.0.bb b/recipes-devtools/python/pamela_0.3.0.bb
new file mode 100644
index 0000000..8071fcb
--- /dev/null
+++ b/recipes-devtools/python/pamela_0.3.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Pamela: yet another Python wrapper for PAM"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=bfb663f37eb99232bc8ccfa4ea8f1202"
+
+SRC_URI[md5sum] = "de6516118d51eb5fc97017f3b6d5c68b"
+SRC_URI[sha256sum] = "1e198446a6cdd87704aa0def7621d62e7c20b0e6068e2788b9a866a8355e5d6b"
+
+PYPI_PACKAGE = "pamela"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} = "libpam"
+
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "pam"