settings: recipe/service update

Use new systemd class features.
Add allarch.

Change-Id: I4836deac6e7f3d07bb8f5291b78c931b0f1f78c0
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/settings/phosphor-settings.bb b/common/recipes-phosphor/settings/phosphor-settings.bb
index 69043f0..3435816 100644
--- a/common/recipes-phosphor/settings/phosphor-settings.bb
+++ b/common/recipes-phosphor/settings/phosphor-settings.bb
@@ -3,9 +3,12 @@
 HOMEPAGE = "http://github.com/openbmc/phosphor-settingsd"
 PR = "r1"
 
+inherit allarch
 inherit obmc-phosphor-license
-inherit obmc-phosphor-systemd
 inherit setuptools
+inherit obmc-phosphor-dbus-service
+
+DBUS_SERVICE_${PN} = "org.openbmc.settings.Host.service"
 
 DEPENDS += "python-pyyaml-native"
 RDEPENDS_${PN} += "python-dbus python-pygobject"
@@ -17,4 +20,3 @@
 SRCREV = "c1e5e9ffb9df84c0f0fdb41e604d1738b6f9bc45"
 
 S = "${WORKDIR}/git"
-