stdplus: Use meson instead of autotools

This will allow us to get rid of autotools in the upstream sources.

Change-Id: I47039a6c56e73c8a45b837daf29295b5cfde98f9
Signed-off-by: William A. Kennington III <wak@google.com>
diff --git a/recipes-extended/stdplus/stdplus_git.bb b/recipes-extended/stdplus/stdplus_git.bb
index 45a699b..845b96e 100644
--- a/recipes-extended/stdplus/stdplus_git.bb
+++ b/recipes-extended/stdplus/stdplus_git.bb
@@ -6,15 +6,11 @@
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
 
-inherit autotools pkgconfig
+inherit meson pkgconfig
 
-DEPENDS += " \
-        autoconf-archive-native \
-        "
-
-EXTRA_OECONF_append += " \
-        --disable-examples \
-        --disable-tests \
+EXTRA_OEMESON = " \
+        -Dexamples=false \
+        -Dtests=disabled \
         "
 
 SRC_URI += "git://github.com/openbmc/stdplus"