phosphor-host-postd: Use meson

Now that meson support is ready, build using meson
instead of autotools

Signed-off-by: Kun Yi <kunyi731@gmail.com>
Change-Id: I2fe839d59ffe142bad45c902de9a7519523bfdfd
diff --git a/recipes-phosphor/host/phosphor-host-postd_git.bb b/recipes-phosphor/host/phosphor-host-postd_git.bb
index e400893..e263cdb 100644
--- a/recipes-phosphor/host/phosphor-host-postd_git.bb
+++ b/recipes-phosphor/host/phosphor-host-postd_git.bb
@@ -6,13 +6,13 @@
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
 
-inherit autotools pkgconfig
+inherit meson
+inherit pkgconfig
 inherit systemd
 
 PACKAGECONFIG ?= ""
-PACKAGECONFIG[7seg] = "--enable-7seg,--disable-7seg,,udev"
+PACKAGECONFIG[7seg] = "-D7seg=enabled,-D7seg=disabled,,udev"
 
-DEPENDS += "autoconf-archive-native"
 DEPENDS += "sdbusplus"
 DEPENDS += "sdeventplus"
 DEPENDS += "phosphor-dbus-interfaces"
@@ -29,11 +29,9 @@
 SYSTEMD_PACKAGES = "${PN}"
 SYSTEMD_SERVICE_${PN} += "${SERVICE_FILE}"
 
-EXTRA_OECONF = " \
-  SNOOP_DEVICE="${SNOOP_DEVICE}" \
-  POST_CODE_BYTES="${POST_CODE_BYTES}" \
-  SYSTEMD_TARGET="multi-user.target" \
-"
+EXTRA_OEMESON += "-Dsnoop-device=${SNOOP_DEVICE}"
+EXTRA_OEMESON += "-Dpost-code-bytes=${POST_CODE_BYTES}"
+EXTRA_OEMESON += "-Dsystemd-target=multi-user.target"
 
 POSTCODE_SEVENSEG_DEVICE ?= "seven_seg_disp_val"
 SERVICE_FILE_7SEG = " \