Add associations support to phosphor-inventory-mgr

Add support so another layer can select the 'associations'
PACKAGECONFIG and install their own associations.json file
which the phosphor-inventory code uses to create associations
between inventory paths and other paths.

Change-Id: I4401560e816455af758b3e54a6158ea7e7cc0c71
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb b/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
index c6e3b29..1b54dd5 100644
--- a/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
+++ b/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
@@ -39,3 +39,6 @@
         IFACE=${OBMC_INVENTORY_MGR_IFACE} \
         IFACES_PATH=${STAGING_DIR_NATIVE}${yaml_dir} \
         "
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[associations] = "--enable-associations, --disable-associations,nlohmann-json,"