Add new LDAP config package

Package app phosphor-ldap-conf. This app implements an API to update
the LDAP config file i.e /etc/nslcd.conf.

This commit also creates a file:/etc/nslcd.conf.default, which is to
be restored as /etc/nslcd.conf when we disable LDAP configuration.

Change-Id: Icde4264f4a9337775563f344fd2e300bf0897c52
Signed-off-by: Nagaraju Goruganti <ngorugan@in.ibm.com>
diff --git a/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend b/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend
new file mode 100644
index 0000000..d1b092d
--- /dev/null
+++ b/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend
@@ -0,0 +1,3 @@
+do_install_append() {
+        install -m 0644 ${D}${sysconfdir}/nslcd.conf ${D}${sysconfdir}/nslcd.conf.default
+}