libgpiod: Enable CXX Headers

Add CXX to packageconfig and change the devtools to
RDEPEND on libgpiod-tools instead as they are the actual
tools. Without changing it to the tools when we enable
cxx the tools do not by default get installed by Yocto.

Tested: gpioinfo still functioned properly on BMC, and was
able to bitbake package using CXX headers for dbus-sensors.

Change-Id: I7888f7b19d986765fb5538c7156d4053ab81927d
Signed-off-by: James Feist <james.feist@linux.intel.com>
diff --git a/recipes-support/libgpiod/libgpiod_%.bbappend b/recipes-support/libgpiod/libgpiod_%.bbappend
new file mode 100644
index 0000000..0ee1845
--- /dev/null
+++ b/recipes-support/libgpiod/libgpiod_%.bbappend
@@ -0,0 +1 @@
+PACKAGECONFIG += " cxx"