phosphor-settings: Remove install step and make it a virtual package

Move the settings dbus object to a virtual package, replace the
dependency from ipmi with a recommends, and update the recipe to
make use of the new python setup script in the phosphor-settingsd
repository.

Change-Id: I0566ed267a6cd5e06f701ba54b1021a9a8268a20
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/common/recipes-phosphor/settings/phosphor-settings.bb b/common/recipes-phosphor/settings/phosphor-settings.bb
new file mode 100644
index 0000000..09d6850
--- /dev/null
+++ b/common/recipes-phosphor/settings/phosphor-settings.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Settings DBUS object"
+DESCRIPTION = "Settings DBUS object"
+HOMEPAGE = "http://github.com/openbmc/phosphor-settingsd"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit obmc-phosphor-systemd
+inherit setuptools
+
+DEPENDS += "python-pyyaml-native"
+RDEPENDS_${PN} += "python-dbus python-pygobject"
+PROVIDES += "virtual/obmc-settings-mgmt"
+RPROVIDES_${PN} += "virtual-obmc-settings-mgmt"
+
+SRC_URI += "git://github.com/openbmc/phosphor-settingsd"
+
+SRCREV = "54be910bd0af885217adc7dfcd95b7db9a13886d"
+
+S = "${WORKDIR}/git"
+