Remove obmc-mrw machine feature

Using MRW or not is distro policy.  As such remove the obmc-mrw
machine feature.

Do not enable the remaining obmc-mrw distro feature in the base
phosphor distro configuration.

Create new distro configs for the systems that use MRW today
(i.e. Witherspoon) that enables the obmc-mrw distro feature and point
the local.conf.sample at the new distro configuration.

Change-Id: If4cedc745b3ee942518fbfd4d5cf2cd5b60f346d
Tested: Built a Witherspoon image and validate the manifest
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/leds/phosphor-led-manager-config-mrw-native.bb b/common/recipes-phosphor/leds/phosphor-led-manager-config-mrw-native.bb
index ef14030..920f637 100644
--- a/common/recipes-phosphor/leds/phosphor-led-manager-config-mrw-native.bb
+++ b/common/recipes-phosphor/leds/phosphor-led-manager-config-mrw-native.bb
@@ -11,7 +11,7 @@
 
 # Generate a YAML files based on MRW input
 do_install_append() {
-    USE_MRW="${@cf_enabled(d, 'obmc-mrw', 'yes')}"
+    USE_MRW="${@df_enabled(d, 'obmc-mrw', 'yes')}"
     DEST=${D}${datadir}/phosphor-led-manager
 
     if [ "${USE_MRW}" = "yes" ]; then