Remove obmc-mrw machine feature

Using MRW or not is distro policy.  As such remove the obmc-mrw
machine feature.

Do not enable the remaining obmc-mrw distro feature in the base
phosphor distro configuration.

Create new distro configs for the systems that use MRW today
(i.e. Witherspoon) that enables the obmc-mrw distro feature and point
the local.conf.sample at the new distro configuration.

Change-Id: If4cedc745b3ee942518fbfd4d5cf2cd5b60f346d
Tested: Built a Witherspoon image and validate the manifest
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/settings/phosphor-settings-manager.bb b/common/recipes-phosphor/settings/phosphor-settings-manager.bb
index 17f727a..a63a1f2 100644
--- a/common/recipes-phosphor/settings/phosphor-settings-manager.bb
+++ b/common/recipes-phosphor/settings/phosphor-settings-manager.bb
@@ -16,7 +16,7 @@
 DEPENDS += "python-mako-native"
 DEPENDS += "autoconf-archive-native"
 DEPENDS += "virtual/phosphor-settings-defaults"
-DEPENDS += "${@cf_enabled(d, 'obmc-mrw', 'phosphor-settings-read-settings-mrw-native')}"
+DEPENDS += "${@df_enabled(d, 'obmc-mrw', 'phosphor-settings-read-settings-mrw-native')}"
 DEPENDS += "sdbusplus sdbusplus-native"
 DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
 DEPENDS += "phosphor-logging"
@@ -48,7 +48,7 @@
     cmd.append(os.path.join(workdir, 'merge_settings.py'))
     cmd.append(os.path.join(settingsdir, 'defaults.yaml'))
     # Used for any settings from the MRW
-    use_mrw = cf_enabled(d, 'obmc-mrw', 'true')
+    use_mrw = df_enabled(d, 'obmc-mrw', 'true')
     if (use_mrw == 'true'):
         cmd.append(os.path.join(settingsdir, 'mrw-settings.override.yaml'))