binutils: allow build on RHEL6

The gcc in RHEL6 does not support a compiler warning enabled
by binutils.  The 'target' compiler generated by Yocto does.

When cross-compiling or creating the SDK, binutils autoconf
detects that the cross-compiler for the 'target' supports this
and then enables it for both 'target' and 'host' compile
invocations.

Since we do not care about compile warnings of a fundamental
package like binutils, disable it via patch.

See openbmc/openbmc#1407 to track removal.

Change-Id: I006ec35fe5b9d67ef4752b66e703f2fd79b46714
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
diff --git a/common/recipes-devtools/binutils/binutils_%.bbappend b/common/recipes-devtools/binutils/binutils_%.bbappend
new file mode 100644
index 0000000..79a0e3d
--- /dev/null
+++ b/common/recipes-devtools/binutils/binutils_%.bbappend
@@ -0,0 +1,3 @@
+# TODO: openbmc/openbmc#1407 - Remove with RHEL6 support deprecation.
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+SRC_URI += "file://0001-Remove-Wstack-usage-to-support-old-gcc.patch"