Use out of (kernel) tree defconfig

I finally figured out how to get kernel config fragments working.
This allows removal of some earlier kernel recipe hacks.
Part 1 of 2 ( meta-phosphor, meta-openbmc-bsp )
diff --git a/common/recipes-kernel/linux/linux-obmc_4.2.bb b/common/recipes-kernel/linux/linux-obmc_4.2.bb
index 81edb70..f49b3fc 100644
--- a/common/recipes-kernel/linux/linux-obmc_4.2.bb
+++ b/common/recipes-kernel/linux/linux-obmc_4.2.bb
@@ -3,16 +3,12 @@
 LICENSE = "GPLv2"
 
 KBRANCH ?= "dev"
+KCONFIG_MODE="--alldefconfig"
 
 SRC_URI = "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}"
-SRC_URI += "file://obmc-bsp.scc \
-            file://obmc-bsp.cfg \
-            file://obmc-bsp-user-config.cfg \
-            file://obmc-bsp-user-patches.scc \
-           "
 
 LINUX_VERSION ?= "4.2"
-LINUX_VERSION_EXTENSION ?= "-openbmc-${SRCPV}"
+LINUX_VERSION_EXTENSION ?= "-${SRCREV}"
 
 SRCREV="openbmc-20151028-1"
 
@@ -22,7 +18,3 @@
 
 inherit kernel
 require recipes-kernel/linux/linux-yocto.inc
-
-do_configure_prepend() {
-        sed -i 's/CONFIG_LOCALVERSION=.\+/CONFIG_LOCALVERSION=${LINUX_VERSION_EXTENSION}/' ${S}/arch/${ARCH}/configs/${KMACHINE}_defconfig
-}