Add recipes for Witherspoon VCS workaround

Create vcs-workaround machine feature p9.inc
Add new recipe vcs-pre-post.bb
Add new recipe p9-vcs-workaround.bb
Add new recipe start_host.bb
Create preferred providers
Create host control machine/distro/image feature
Add dependencies

Partially resolves openbmc/openbmc#647

Change-Id: I285cafc81afda20977fdf360ad8ad34d15e38685
Signed-off-by: Sergey Solomin <sergey.solomin@us.ibm.com>
diff --git a/common/recipes-phosphor/hosts/obmc-op-control-host.bb b/common/recipes-phosphor/hosts/obmc-op-control-host.bb
index dabc4a8..2b5e8b1 100644
--- a/common/recipes-phosphor/hosts/obmc-op-control-host.bb
+++ b/common/recipes-phosphor/hosts/obmc-op-control-host.bb
@@ -5,6 +5,9 @@
 inherit skeleton-gdbus
 inherit obmc-phosphor-dbus-service
 
+PROVIDES += "virtual/obmc-host-ctl"
+RPROVIDES_${PN} += "virtual-obmc-host-ctl"
+
 SKELETON_DIR = "op-hostctl"
 
 FMT = "org.openbmc.control.Host@{0}.service"