BMC: Update u-boot environment variables.

- Create a service file that can update the u-boot variables
  (kernelname, root and ubiblock) to point to a different
  BMC version.
- This service file will be called by the BMC ItemUpdater
  if a user sets BMC version priority to the lowest value.

Change-Id: Ic83c7e7a1c36eefc6c0b1b12b2077f5a866db36c
Signed-off-by: Saqib Khan <khansa@us.ibm.com>
diff --git a/common/recipes-phosphor/flash/phosphor-software-manager.bb b/common/recipes-phosphor/flash/phosphor-software-manager.bb
index d4b4b4a..b54bd50 100644
--- a/common/recipes-phosphor/flash/phosphor-software-manager.bb
+++ b/common/recipes-phosphor/flash/phosphor-software-manager.bb
@@ -74,6 +74,7 @@
     obmc-flash-bmc-ubiro-remove@.service \
     usr-local.mount \
     obmc-flash-bmc-ubiremount.service \
+    obmc-flash-bmc-updateubootvars@.service \
     "
 
 # Name of the mtd device where the ubi volumes should be created