ipmi: Refactor whitelist generation

The current dual-use of packagegroup-ipmid-providers as a
dependency insertion point for both native (whitelists) and
runtime (provider libs) doesn't work under Yocto 2.3.

Move the ipmi provider configuration from recipe scope to
the global configuration scope so we can continue to avoid
dually maintaining whitelist and provider lists _and_ build
under Yocto 2.3.

Also rename OBMC_IPMID_PROVIDERS with the more conventional
VIRTUAL-RUNTIME_phosphor-ipmi-providers.

Change-Id: I1acce0b08047cba2312f60542942cccbcff66aec
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb b/common/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb
index 87d17f9..cbe7e7f 100644
--- a/common/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb
+++ b/common/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb
@@ -7,12 +7,5 @@
 PROVIDES = "${PACKAGES}"
 PACKAGES = "${PN}-libs"
 
-OBMC_IPMID_PROVIDERS = "phosphor-ipmi-fru"
-
 SUMMARY_${PN}-libs = "Extra providers for ipmid."
-RDEPENDS_${PN}-libs = "${OBMC_IPMID_PROVIDERS}"
-
-WHITELIST_FORMAT = "{0}-whitelist-native"
-OBMC_IPMID_WHITELISTS = "${@compose_list(d, 'WHITELIST_FORMAT', 'OBMC_IPMID_PROVIDERS')}"
-
-DEPENDS_append = "${OBMC_IPMID_WHITELISTS}"
+RDEPENDS_${PN}-libs = "${VIRTUAL-RUNTIME_phosphor-ipmi-providers}"