fix json dbus.Double encoding

- bad formatting showed up in rest server queries
- json used the highest level repr method, which will call the dbus type
tp_repr method. Instead we should use the float specific repr method.

resolves openbmc/openbmc#411

Change-Id: I04eea6d825fe3833accf1625e138abedb0aa7c95
Signed-off-by: Edward A. James <eajames@us.ibm.com>
diff --git a/common/recipes-devtools/python/python_2.7.11.bbappend b/common/recipes-devtools/python/python_2.7.11.bbappend
index 569e753..f5c58e3 100644
--- a/common/recipes-devtools/python/python_2.7.11.bbappend
+++ b/common/recipes-devtools/python/python_2.7.11.bbappend
@@ -1,5 +1,6 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 SRC_URI += "file://__init__.email_min.py"
+SRC_URI += "file://issue_27934_use-float-repr.patch"
 
 do_install_append_class-target() {
 	dir=${libdir}/python${PYTHON_MAJMIN}/email