obmc-phosphor-initramfs: Remove udev

We aren't actually using udev during the initrd stage, and it takes and
extra 500KB compressed worth of space in the file.

For some reason the udev dependency pulls in the native shadow
functionality which we have been implicitly depending on. This
explicitly calls out that dependency.

Change-Id: Ib5ecbd59deba53de8db98c195ecb11c90c6c3df0
Signed-off-by: William A. Kennington III <wak@google.com>
diff --git a/recipes-phosphor/images/obmc-phosphor-initramfs.bb b/recipes-phosphor/images/obmc-phosphor-initramfs.bb
index d77f92c..3f0b3c1 100644
--- a/recipes-phosphor/images/obmc-phosphor-initramfs.bb
+++ b/recipes-phosphor/images/obmc-phosphor-initramfs.bb
@@ -2,7 +2,7 @@
 the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
 first 'init' program more efficiently."
 
-PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} obmc-phosphor-initfs"
+PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} obmc-phosphor-initfs"
 
 # Do not pollute the initrd image with rootfs features
 IMAGE_FEATURES = ""
@@ -18,6 +18,9 @@
 IMAGE_ROOTFS_SIZE = "8192"
 IMAGE_ROOTFS_EXTRA_SPACE = "0"
 
+# Needed for the set_user_group functions to succeed
+DEPENDS += "shadow-native"
+
 PACKAGE_INSTALL_remove = "shadow"
 PACKAGE_EXCLUDE = "shadow"
 BAD_RECOMMENDATIONS += "busybox-syslog"