inventory: Remove sample object

Replace the example yaml with an empty configuration by default.
Rename OBMC_INVENTORY_PROVIDERS to PHOSPHOR_INVENTORY_MANAGER_CONFIGS
 since this variable does not define structure.

Change-Id: I2d64bb21029ac433c018ba6258c1f11dcd0ff002
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-native.bb b/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-native.bb
index 1377336..bc65eec 100644
--- a/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-native.bb
+++ b/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-native.bb
@@ -7,9 +7,9 @@
 inherit obmc-phosphor-license
 inherit native
 
-OBMC_INVENTORY_PROVIDERS ??= "phosphor-inventory-manager-config-example-native"
+PHOSPHOR_INVENTORY_MANAGER_CONFIGS ??= ""
 
 # To add additional managed inventory items, create a recipe in your layer,
-# and add it to OBMC_INVENTORY_PROVIDERS with a bbappend to this recipe.
+# and add it to PHOSPHOR_INVENTORY_MANAGER_CONFIGS with a bbappend to this recipe.
 
-DEPENDS += "${OBMC_INVENTORY_PROVIDERS}"
+DEPENDS += "${PHOSPHOR_INVENTORY_MANAGER_CONFIGS}"