initramfs: Add init script for eMMC

This init script mounts the rootfs based on the root u-boot env
variable, mounts the read-write filesystem and sets up the overlay.

Change-Id: Id122f426822bddf12c04819e0b93ed2daa4ab7f6
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/recipes-phosphor/images/obmc-phosphor-initramfs.bb b/recipes-phosphor/images/obmc-phosphor-initramfs.bb
index 739aab5..4c7237f 100644
--- a/recipes-phosphor/images/obmc-phosphor-initramfs.bb
+++ b/recipes-phosphor/images/obmc-phosphor-initramfs.bb
@@ -2,7 +2,11 @@
 the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
 first 'init' program more efficiently."
 
-PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} obmc-phosphor-initfs"
+# Init scripts
+INIT_PACKAGE = "obmc-phosphor-initfs"
+INIT_PACKAGE_df-phosphor-mmc = "phosphor-mmc-init"
+
+PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} ${INIT_PACKAGE}"
 
 # Do not pollute the initrd image with rootfs features
 IMAGE_FEATURES = "read-only-rootfs"