Rename and move kernel recipe

Rename linux-obmc to linux-aspeed and move to the Aspeed
layer.  Like recipes for u-boot forks, recipes for kernel
forks in support of different SOCs are typically provided
in the BSP supporting the SOC.

Moved a number of phosphor-isms out of the kernel recipe and put
those in a bbappend in aspeed-layer/bbappend.

Removed COMPATIBLE_MACHINE setting.  We simply use PREFERRED_PROVIDER
in machine configuration files to set the default kernel recipe.

Tested: Booted spoon/palmetto images using QEMU
Change-Id: I7dc73629cad4789dcd5aeb0f7b6214fe064c6adc
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend b/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend
new file mode 100644
index 0000000..b8c40c5
--- /dev/null
+++ b/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend
@@ -0,0 +1,12 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://phosphor-gpio-keys.scc"
+SRC_URI += "file://phosphor-gpio-keys.cfg"
+SRC_URI += "file://phosphor-vlan.scc"
+SRC_URI += "file://phosphor-vlan.cfg"
+SRC_URI += "file://phosphor-wdt-on-panic.scc"
+SRC_URI += "file://phosphor-wdt-on-panic.cfg"
+SRC_URI_append_df-obmc-ubi-fs = " file://0001-ARM-dts-Aspeed-Witherspoon-Update-BMC-partitioning.patch"
+
+KERNEL_FEATURES_append = " phosphor-vlan"
+KERNEL_FEATURES_remove_qemuall = " phosphor-vlan"