jsnbd: Add config.json file

The nbd-proxy app expects a config.json file installed in
/etc/nbd-proxy/, use the default file provided in the repo.

This file can be overridden by creating a new file in a meta
layer, then adding the following lines to a jsnbd_%.bbappend:

  FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
  SRC_URI += "file://config.json"
  NBD_PROXY_CONFIG_JSON = "${WORKDIR}/config.json"

Tested: Verified the default file is installed in the image and
that the nbd-proxy app finds it. Also checked that the file can
be overridden with a bbappend.

Change-Id: Id833d89dffc04ecdb8d32853ffe070ce530bdfbe
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/recipes-connectivity/jsnbd/jsnbd_git.bb b/recipes-connectivity/jsnbd/jsnbd_git.bb
index b5e1240..f919547 100644
--- a/recipes-connectivity/jsnbd/jsnbd_git.bb
+++ b/recipes-connectivity/jsnbd/jsnbd_git.bb
@@ -16,3 +16,10 @@
 
 SRC_URI = "git://github.com/openbmc/jsnbd"
 SRCREV = "d5b9857609401e3cf9c53b111134a6aab8e4573c"
+
+NBD_PROXY_CONFIG_JSON ??= "${S}/config.sample.json"
+
+do_install_append() {
+    install -d ${D}${sysconfdir}/nbd-proxy/
+    install -m 0644 ${NBD_PROXY_CONFIG_JSON} ${D}${sysconfdir}/nbd-proxy/config.json
+}