noverify-bmc-update: Only commit payload on update

We don't want to allow indirect updates via users issuing `mc reboot
cold` commands after verifying but without peforming the update step.

Change-Id: I42eadfbe41949d15c1ed5475d96d5c2a630a2fa0
Signed-off-by: William A. Kennington III <wak@google.com>
Fixed misspelling of command
Signed-off-by: Brad Bishop<bradleyb@fuzziesquirrel.com>
diff --git a/recipes-phosphor/flash/noverify-bmc-update.bb b/recipes-phosphor/flash/noverify-bmc-update.bb
index fb1480f..503e836 100644
--- a/recipes-phosphor/flash/noverify-bmc-update.bb
+++ b/recipes-phosphor/flash/noverify-bmc-update.bb
@@ -4,9 +4,11 @@
 
 inherit systemd
 
+SRC_URI += "file://noverify-bmc-update.service"
 SRC_URI += "file://noverify-bmc-verify.service"
 SRC_URI += "file://config-bmc.json"
 
+SYSTEMD_SERVICE_${PN} += "noverify-bmc-update.service"
 SYSTEMD_SERVICE_${PN} += "noverify-bmc-verify.service"
 FILES_${PN} += "${datadir}/phosphor-ipmi-flash/config-bmc.json"
 
@@ -15,5 +17,6 @@
   install -m 0644 ${WORKDIR}/config-bmc.json ${D}${datadir}/phosphor-ipmi-flash
 
   install -d ${D}${systemd_system_unitdir}
+  install -m 0644 ${WORKDIR}/noverify-bmc-update.service ${D}${systemd_system_unitdir}
   install -m 0644 ${WORKDIR}/noverify-bmc-verify.service ${D}${systemd_system_unitdir}
 }