systemd - Shrink systemd package contents

Eliminate unnecessary items installed by systemd
package. That will save some space and reduce
a number of files on a system.

Resolves openbmc/openbmc#222

Change-Id: I1d51f82052b782a3ff3bd3821ecf39608a5ac8ce
Signed-off-by: Sergey Solomin <sergey.solomin@us.ibm.com>
diff --git a/common/recipes-core/systemd/systemd_%.bbappend b/common/recipes-core/systemd/systemd_%.bbappend
index 54ea26a..feaeaf9 100644
--- a/common/recipes-core/systemd/systemd_%.bbappend
+++ b/common/recipes-core/systemd/systemd_%.bbappend
@@ -1,5 +1,9 @@
+FILES_${PN}-catalog-extralocales = \
+            "${exec_prefix}/lib/systemd/catalog/*.*.catalog"
+PACKAGES =+ "${PN}-catalog-extralocales"
 PACKAGECONFIG_append = " networkd"
-PACKAGECONFIG_remove = "machined hibernate ldconfig binfmt backlight quotacheck localed kdbus ima smack polkit"
+PACKAGECONFIG_remove = "machined hibernate ldconfig binfmt backlight localed \
+                        quotacheck kdbus ima smack polkit logind bootchart utmp"
 FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
 SRC_URI += "file://default.network"
 SRC_URI += "file://0001-Export-message_append_cmdline.patch"