Replace iteritems() with items() in systemd

Deprecated iteritems() method is not forward-compatible
with python3 and is replaced by items()

Change-Id: Ic6b57da360149c378118673b966bde189d8e2493
Signed-off-by: Saqib Khan <khansa@us.ibm.com>
diff --git a/classes/obmc-phosphor-systemd.bbclass b/classes/obmc-phosphor-systemd.bbclass
index d302ca5..7446d4b 100644
--- a/classes/obmc-phosphor-systemd.bbclass
+++ b/classes/obmc-phosphor-systemd.bbclass
@@ -230,7 +230,7 @@
             spec, file = spec.rsplit(':', 1)
             all_subs.setdefault(file, []).append(spec)
 
-        for f, v in all_subs.iteritems():
+        for f, v in all_subs.items():
             subs = dict([ x.split(':') for x in v])
             if not subs:
                 continue