meta-phosphor: hwmon: set as git recipe

Renamed the phosphor-hwmon.bb to phosphor-hwmon_git.bb.  This recipe is
old, however, a search through openbmc found all upstream layers
properly appended this recipe to allow for such a change.

Change-Id: I7d93ab678bb66707b55e33adae9a5a0694d441b8
Signed-off-by: Patrick Venture <venture@google.com>
diff --git a/recipes-phosphor/sensors/phosphor-hwmon_git.bb b/recipes-phosphor/sensors/phosphor-hwmon_git.bb
new file mode 100644
index 0000000..14f2dac
--- /dev/null
+++ b/recipes-phosphor/sensors/phosphor-hwmon_git.bb
@@ -0,0 +1,56 @@
+SUMMARY = "OpenBMC hwmon poller"
+DESCRIPTION = "OpenBMC hwmon poller."
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-systemd
+
+PACKAGE_BEFORE_PN = "max31785-msl"
+SYSTEMD_PACKAGES = "${PN} max31785-msl"
+
+SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Hwmon@.service"
+SYSTEMD_SERVICE_max31785-msl = "phosphor-max31785-msl@.service"
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += " \
+        sdbusplus \
+        phosphor-dbus-interfaces \
+        phosphor-logging \
+        gpioplus \
+        "
+
+
+RDEPENDS_${PN} += "\
+        sdbusplus \
+        phosphor-dbus-interfaces \
+        phosphor-logging \
+        gpioplus \
+        bash \
+        "
+
+RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_phosphor-hwmon-config}"
+
+FILES_max31785-msl = "${bindir}/max31785-msl"
+RDEPENDS_max31785-msl = "${VIRTUAL-RUNTIME_base-utils} i2c-tools"
+
+SRC_URI += "git://github.com/openbmc/phosphor-hwmon"
+SRC_URI += "file://70-hwmon.rules"
+SRC_URI += "file://70-iio.rules"
+SRC_URI += "file://start_hwmon.sh"
+
+SRCREV = "b28f432a3fdb96c634e93ea27807daec59a941e7"
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+
+        install -d ${D}/${base_libdir}/udev/rules.d/
+        install ${WORKDIR}/70-hwmon.rules ${D}/${base_libdir}/udev/rules.d/
+        install ${WORKDIR}/70-iio.rules ${D}/${base_libdir}/udev/rules.d/
+
+        install -d ${D}${bindir}
+        install -m 0755 ${WORKDIR}/start_hwmon.sh ${D}${bindir}
+}