meta-phosphor: fix reboot of BMC

After the commit bba38f38e7e41525c30116a2fe990d113b8157da the firmware
with a static flash layout is unable to reboot.
It happens because the `reboot` applet was removed from the `busybox`.

This commit restore the `reboot` in the `busybox` for static layout.

Resolves openbmc/openbmc#3399

Tested in the `qemu` with firmwares for `palmetto` and `romulus`.

Change-Id: I11ff21ad1157741e6ae2bf6a11a42eab9e577e6a
Signed-off-by: Alexander Filippov <a.filippov@yadro.com>
diff --git a/recipes-core/busybox/busybox_%.bbappend b/recipes-core/busybox/busybox_%.bbappend
index e6678fc..cc88bcc 100644
--- a/recipes-core/busybox/busybox_%.bbappend
+++ b/recipes-core/busybox/busybox_%.bbappend
@@ -3,3 +3,4 @@
 SRC_URI += "file://flash.cfg"
 SRC_URI += "file://mountpoint.cfg"
 SRC_URI += "file://0001-Stop-watchdog-first-on-startup.patch"
+SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'obmc-ubi-fs', '', 'file://reboot.cfg', d)}"