Add cjson recipe

CJson is a support library implementing json support for C libraries.
It is relatively small, and compliant enough for secure systems usage.
More information can be found in the CJson homepage here:

https://github.com/DaveGamble/cJSON

Tested by: "bitbake cjson" and saw no build failures.

Change-Id: Id36f8fd051875d9d0356fc6834ceca977ca54146
Signed-off-by: Ed Tanous <ed.tanous@intel.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-support/cjson/cjson_git.bb b/common/recipes-support/cjson/cjson_git.bb
new file mode 100644
index 0000000..096e3c9
--- /dev/null
+++ b/common/recipes-support/cjson/cjson_git.bb
@@ -0,0 +1,15 @@
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=218947f77e8cb8e2fa02918dc41c50d0"
+
+SRC_URI = "git://github.com/DaveGamble/cJSON.git"
+
+PV = "1.7.6+git${SRCPV}"
+SRCREV = "cbc05de76fbd4dfff17b5626d5cfe9ec922b1f4a"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+FILES_${PN}-dev += "${libdir}/cmake/cJSON/*"
+
+EXTRA_OECMAKE = "-DENABLE_CUSTOM_COMPILER_FLAGS=OFF -DENABLE_TARGET_EXPORT=OFF"