Introducing the Phosphor OpenBMC OE layer

 -Codifies the IBM vision for an OpenBMC build system.
 -Structured around a core DBUS API architecture.
 -Provides implementation flexibility within that architecture.
 -Provides sample qemuarm BSP layer.
diff --git a/classes/obmc-phosphor-c-daemon.bbclass b/classes/obmc-phosphor-c-daemon.bbclass
new file mode 100644
index 0000000..e21d17c
--- /dev/null
+++ b/classes/obmc-phosphor-c-daemon.bbclass
@@ -0,0 +1,17 @@
+# Common code for dbus applications using c.
+
+inherit obmc-phosphor-systemd
+inherit obmc-phosphor-license
+
+DEPENDS += "glib-2.0"
+SRC_URI += " \
+        file://Makefile \
+        file://${PN}.c \
+        "
+S = "${WORKDIR}"
+
+do_install_append() {
+        # install the binary
+        install -d ${D}${sbindir}
+        install -m 0755 ${WORKDIR}/${PN} ${D}${sbindir}
+}