Introducing the Phosphor OpenBMC OE layer
-Codifies the IBM vision for an OpenBMC build system.
-Structured around a core DBUS API architecture.
-Provides implementation flexibility within that architecture.
-Provides sample qemuarm BSP layer.
diff --git a/classes/obmc-phosphor-systemd.bbclass b/classes/obmc-phosphor-systemd.bbclass
new file mode 100644
index 0000000..7bd2d9d
--- /dev/null
+++ b/classes/obmc-phosphor-systemd.bbclass
@@ -0,0 +1,14 @@
+# Common code for Phosphor OpenBMC systemd services.
+
+inherit systemd
+
+SYSTEMD_SERVICE_${PN} = "${PN}.service"
+SRC_URI += " \
+ file://${PN}.service \
+ "
+
+do_install_append() {
+ # install systemd unit files
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/${PN}.service ${D}${systemd_unitdir}/system
+}