Introducing the Phosphor OpenBMC OE layer

 -Codifies the IBM vision for an OpenBMC build system.
 -Structured around a core DBUS API architecture.
 -Provides implementation flexibility within that architecture.
 -Provides sample qemuarm BSP layer.
diff --git a/classes/obmc-phosphor-utils.bbclass b/classes/obmc-phosphor-utils.bbclass
new file mode 100644
index 0000000..4f55629
--- /dev/null
+++ b/classes/obmc-phosphor-utils.bbclass
@@ -0,0 +1,14 @@
+# Helper functions for checking feature variables.
+
+inherit utils
+
+def df_enabled(feature, value, d):
+        return base_contains("DISTRO_FEATURES", feature, value, "", d)
+
+def mf_enabled(feature, value, d):
+        return base_contains("MACHINE_FEATURES", feature, value, "", d)
+
+def cf_enabled(feature, value, d):
+        return value if df_enabled(feature, value, d) \
+                and mf_enabled(feature, value, d) \
+                        else ""